Cloth Diapers & Parenting Community - DiaperSwappers.com

Cloth Diapers & Parenting Community - DiaperSwappers.com (http://www.diaperswappers.com/forum/index.php)
-   Pumping Support (http://www.diaperswappers.com/forum/forumdisplay.php?f=192)
-   -   Medela Swing- ? (http://www.diaperswappers.com/forum/showthread.php?t=1396800)

grateful mama13 05-21-2012 01:06 PM

Medela Swing- ?
 
I have a medela swing.. when I wash it I sometimes have a hard time getting the membrane( i think is what its called) off.. the little yellow part /w the flap on it. and when i go to pump i have no suction.. I don't know what i'm doing wrong here.. ? I'm almost positive it has something to do with that piece.. but it looks normal to me.. anyone else have this problem or know what im doing wrong?

AHeartLikeMine 06-10-2012 02:50 AM

Re: Medela Swing- ?
 
Maybe you're not putting it back on correctly - could it be loose? Or maybe the membranes need replaced.

e_roehm23 06-11-2012 08:55 PM

Re: Medela Swing- ?
 
You are suppose to wash the yellow piece and the white membrane after every use. I thought I could get away with not washing every time, but ended up having the same problems as you describe. Then I started washing more frequently (not after every use) and the problem was solved. I still had to replace the white membrane quite often, but not the yellow piece so much. Now I have a Medela Freestyle and I still loose suction if I don't wash the membrane & pump parts regularly enough, but I haven't had to replace anything with it yet.


All times are GMT -6. The time now is 01:57 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors